summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJuan2016-10-30 12:43:12 -0400
committerJuan2016-10-30 12:43:12 -0400
commita9c3f2e25efacd23114f62717ea713ea5cceb4ef (patch)
tree513a90012a1b6e286be6ccb654ea8cf1bcee7714 /PKGBUILD
parent85517860025e3aaa044634d43c7428d643eec480 (diff)
downloadaur-a9c3f2e25efacd23114f62717ea713ea5cceb4ef.tar.gz
you could get more benefits from this script with wifi
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6cdc248aeb17..96d04c279ac9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=vpnks
pkgver=1.0
-pkgrel=1
+pkgrel=3
pkgdesc="VPNKS protects you against leaks caused by disconnetction"
arch=('any')
url="https://github.com/plasticbrain/vpnkillswitch"
license=('GPL')
-depends=('networkmanager' 'libnm-glib' 'networkmanager-openvpn' 'nm-connection-editor' 'openvpn')
+depends=('networkmanager' 'libnm-glib' 'networkmanager-openvpn' 'nm-connection-editor' 'openvpn' 'systemd')
makedepends=('bash')
source=(https://github.com/plasticbrain/vpnkillswitch/archive/master.zip)
md5sums=('763d77798dc0ce97e3a7bf700e4fec7c')
@@ -18,6 +18,7 @@ sha384sums=('5d3fe6b1d25fbef52c50c4e39f848836d635f028093ebd98f0a077485f659123b22
sha512sums=('fb35d31ddf88cd25c0e81efdd99c52f69444a08015e4b7585fcbcb804623b035b36433ee508956f1d1ac8b852812912a2cc3afcb1fa504a4d355ea785dda8d3c')
package() {
+ sed 's/eth0/wlp0s29f7u3/' ${srcdir}/vpnkillswitch-master/vpnkillswitch.sh
echo "Please replace eth0 with your network interface at vpnkillswitch.sh"
mkdir -p "${pkgdir}/usr/bin"
for file in ${srcdir}/vpnkillswitch-master/*.sh
@@ -25,6 +26,7 @@ package() {
install -D -m644 "${file}" "${pkgdir}/usr/bin/"
done
echo "If you've questions about this package, please read: http://mikeeverhart.net/2015/12/vpn-killswitch-bash-script/"
+ echo "For recovery your connection please run # vpnkillswitch up"
}
# vim:set ts=2 sw=2 et: