summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Peukert2024-02-04 15:14:30 +0100
committerDaniel Peukert2024-02-04 15:14:30 +0100
commit9ff25548c6aa289ab7fa838976643e3020ee4582 (patch)
treebe85c2a8811a427aff2fa3a81409d6dd742aa106 /PKGBUILD
parent9c2f2b1e6f552d12ea2ba0e889f00aaa233c166a (diff)
downloadaur-9ff25548c6aa289ab7fa838976643e3020ee4582.tar.gz
Update vrf-decompiler to 8.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fe8a77149c5a..0c13297f1906 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Peukert <daniel@peukert.cc>
pkgname='vrf-decompiler'
_reponame='ValveResourceFormat'
-pkgver='7.0'
+pkgver='8.0'
pkgrel='1'
pkgdesc="File data viewer and decompiler for Valve's Source 2 resource file format"
arch=('x86_64' 'armv7h' 'aarch64')
@@ -36,7 +36,7 @@ prepare() {
export DOTNET_SKIP_FIRST_TIME_EXPERIENCE='true'
export DOTNET_CLI_TELEMETRY_OPTOUT='true'
- # Get rid of the dependency on the prebuild SkiaSharp library, as we use the system one
+ # Get rid of the dependency on the prebuilt SkiaSharp library, as we use the system one
sed -i '/"SkiaSharp\.NativeAssets\.Linux\.NoDependencies"/d' 'ValveResourceFormat/ValveResourceFormat.csproj'
# Download dependencies
@@ -56,6 +56,13 @@ build() {
dotnet publish --verbosity 'normal' --configuration 'Release' -p:EnableSourceControlManagerQueries=false --runtime "$_dotnetarch" --self-contained false 'Decompiler/Decompiler.csproj'
}
+check() {
+ cd "$srcdir/$_sourcedirectory/"
+
+ # Verify that the basic functionality works
+ "./Decompiler/bin/Release/$_dotnetarch/publish/Decompiler" -i 'Tests/Files/small_map_with_material.vpk' -l
+}
+
package() {
cd "$srcdir/$_sourcedirectory/"
install -Dm755 "$srcdir/$_sourcedirectory/Decompiler/bin/Release/$_dotnetarch/publish/Decompiler" "$pkgdir/usr/bin/$pkgname"