summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartino Pilia2021-06-22 18:03:16 +0200
committerMartino Pilia2021-06-22 18:03:16 +0200
commit29d4964af7c309a47ee1d1972571dc37d1f4d601 (patch)
treec8cff3e08621914cec391634bb962225ee67cd8c /PKGBUILD
parent7aa8167ee565666f609894a87c0964368bd1e623 (diff)
downloadaur-29d4964af7c309a47ee1d1972571dc37d1f4d601.tar.gz
Remove npm --root flag
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da1881562830..bd143c2472b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer of this PKGBUILD file: Martino Pilia <martino.pilia@gmail.com>
pkgname=vsce
pkgver=1.93.0
-pkgrel=1
+pkgrel=2
pkgdesc="Visual Studio Code extension manager"
arch=('any')
url="https://github.com/Microsoft/vscode-vsce"
@@ -17,13 +17,16 @@ sha256sums=('f4c720e219981a3870ef6d93d12d017ff5f1b203b3f0eae022e9aec6a03b0808')
package() {
npm install -g \
- --user root \
--prefix "$pkgdir"/usr \
"$srcdir"/$pkgname-$pkgver.tgz
# Non-deterministic race in npm gives 777 permissions to random directories.
- # See https://github.com/npm/npm/issues/9359 for details.
- find "${pkgdir}"/usr -type d -exec chmod 755 {} +
+ # See https://github.com/npm/cli/issues/1103 for details.
+ find "${pkgdir}/usr" -type d -exec chmod 755 {} +
+
+ # npm gives ownership of ALL FILES to build user
+ # https://bugs.archlinux.org/task/63396
+ chown -R root:root "${pkgdir}"
# Fix ownership
chown -R root:root "${pkgdir}"/*