summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZhanibek Adilbekov2022-10-07 01:40:46 +0600
committerZhanibek Adilbekov2022-10-07 01:40:46 +0600
commit0a0cddb90419e04fc2ceaf28fcc1b8e6190d8f7b (patch)
tree9b8fd130b882bbd5b588c40dc37a8d387e559ff4 /PKGBUILD
downloadaur-0a0cddb90419e04fc2ceaf28fcc1b8e6190d8f7b.tar.gz
build: version 1.28.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f7686c382e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Zhanibek Adilbekov <zhanibek.adilbekov@proton.me>
+pkgname=vscode-php-debug
+pkgver=1.28.0
+pkgrel=1
+pkgdesc='PHP Debug Adapter (DAP)'
+arch=('any')
+url="https://github.com/xdebug/$pkgname"
+license=('MIT')
+depends=('nodejs')
+source=("extension.zip::https://github.com/xdebug/vscode-php-debug/releases/download/v$pkgver/php-debug-$pkgver.vsix")
+b2sums=('96710618ce939c7be45c7f5d1066f91638badffb8cd8dd86d08430f0fbe84f8eafac20ae6c0c0ee4242dc3e78db9e146d9566a9301f8ce0ba7cba20a879ce760')
+
+package() {
+ install -dm755 "$pkgdir/usr/lib/node_modules/php-debug"
+ cp -r "$srcdir/extension"/. "$pkgdir/usr/lib/node_modules/php-debug"
+ install -Dm644 "$srcdir/extension/LICENSE.txt" "$pkgdir/usr/share/licenses/php-debug/LICENSE.txt"
+}