summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPlague Doctor2019-11-09 11:32:36 +1100
committerPlague Doctor2019-11-09 11:32:36 +1100
commite318abd149ccf82050c41dfe14d8fab5f5665fd2 (patch)
treece72e9e11ae1cccffbc895ef6033b2c01fb72d97 /PKGBUILD
parent44459bf220563e8877819d1e03782b442fb57b15 (diff)
downloadaur-e318abd149ccf82050c41dfe14d8fab5f5665fd2.tar.gz
Fix (sym)links.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 78f3aa6b35dd..9f0db9842ae6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=vscodium-bin
pkgver=1.40.0
-pkgrel=1
+pkgrel=2
pkgdesc="Binary releases of VS Code without MS branding/telemetry/licensing."
arch=('x86_64')
url="https://github.com/VSCodium/vscodium"
@@ -22,7 +22,7 @@ source=(
${pkgname}-${pkgver}-${pkgrel}.tar.gz::${url}/releases/download/${pkgver}/VSCodium-linux-x64-${pkgver}.tar.gz
)
noextract=("${pkgname}-${pkgver}-${pkgrel}.tar.gz")
-sha256sums=('7275ddd94fc356374ca2a883bd1210863a8f2e5ad2f3e6194a42240941d119a4'
+sha256sums=('31fbf764608b74abedaa4dbb5bf8b7d62570345e2a7079bdbc156e5f7c2357ff'
'4482f533bc639d0462a0b98f1a5a13f0adf50a4e7bb75102280bee18297c217a')
prepare() {
@@ -34,6 +34,7 @@ package() {
install -d -m755 ${pkgdir}/usr/bin
install -d -m755 ${pkgdir}/usr/share/{${pkgname},applications,pixmaps}
cp -r ${srcdir}/${pkgname} ${pkgdir}/usr/share
+ ln -s /usr/share/${pkgname}/bin/codium ${pkgdir}/usr/bin/code
ln -s /usr/share/${pkgname}/bin/codium ${pkgdir}/usr/bin/codium
ln -s /usr/share/${pkgname}/bin/codium ${pkgdir}/usr/bin/vscodium
install -D -m644 vscodium-bin.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop