summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIcelk2023-03-18 22:20:11 +0100
committerIcelk2023-03-18 22:20:11 +0100
commit52d65c741c48c4db5c2f275c2453137e06786a18 (patch)
treead7f3c9001aa4542ce83935a5a6229e162d519b2 /PKGBUILD
parent333a97a1618cbe4c2fdf0b613b9c35ae27450142 (diff)
downloadaur-vscodium-bin-marketplace.tar.gz
Use python to change product.json instead of sed.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 56a8bf016050..e2b59640402b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,22 @@
# Maintainer: Icelk <main at icelk.dev>
pkgname=vscodium-bin-marketplace
-pkgver=1.56.0
-pkgrel=7
+pkgver=1.76.0
+pkgrel=1
pkgdesc='Enable vscode marketplace in vscodium-bin'
arch=('any')
url='https://marketplace.visualstudio.com/vscode'
license=('unknown')
install="${pkgname}.install"
source=('vscodium-bin-marketplace.hook'
- 'patch.sh')
-sha256sums=('bd53744ef5bd5b0521af26f9f0774e92f39d37a19d3fb76ed764e591e8052c00'
- '891ff64322af487b247e12548042ab24aa21236e383011787260093d6ae5500a')
+ 'patch.py')
+ sha256sums=('a5236b4dd9662e7015e39593eb1611059cf35c202f538518ca04089dbe701958'
+ 'eb25bec26234a9493f7632c387d8d0963bb5dfd625478a19a32b6c2a1f37c090')
+
package() {
- depends=('vscodium-bin' 'sed')
+ depends=('vscodium-bin' 'python')
install -Dm 644 "${srcdir}"/vscodium-bin-marketplace.hook "${pkgdir}"/usr/share/libalpm/hooks/vscodium-bin-marketplace.hook
- install -Dm 755 "${srcdir}"/patch.sh "${pkgdir}"/opt/vscodium-bin/resources/app/patch.sh
+ install -Dm 755 "${srcdir}"/patch.py "${pkgdir}"/opt/vscodium-bin/resources/app/patch.py
}