summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthias Lisin2019-10-01 21:24:52 +0200
committerMatthias Lisin2019-10-01 21:24:52 +0200
commit14c5f3d91c53c798e20171881a82329a68c9ed65 (patch)
tree92447b75ca2f616c20819d3bbbd51c6f4441eb97 /PKGBUILD
parent7e363ded87a0ae68377a81edcc301d481c249d27 (diff)
downloadaur-14c5f3d91c53c798e20171881a82329a68c9ed65.tar.gz
upgpkg: vt-cli 0.7.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1f073c58eb4e..9d4233fa4dc8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Matthias Lisin <ml@visu.li
pkgname=vt-cli
-pkgver=0.6.1
+pkgver=0.7.0
pkgrel=1
pkgdesc='VirusTotal Command Line Interface'
arch=('i686' 'x86_64')
@@ -8,7 +8,7 @@ url='https://github.com/VirusTotal/vt-cli'
license=('Apache')
makedepends=('go' 'dep')
source=("$pkgname-$pkgver.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha512sums=('2e1a986e6e52afc0d34c8966ad29e3fca5e66b4a87dd2bed1a03c877694bccba26b44b2831d639248421f6eb0b45b72497f2caefcfcdad73da955e5d4f977b78')
+sha512sums=('2064b4a34c80ae71b199c870acef4a42f64f79718bb1cd74eb00027b47f334fba23287433be8d86995a9a82fd0f1bbf8c243b6177612005eea7900cdfe3968d0')
_gopkg=gopath/src/github.com/VirusTotal/"$pkgname"
prepare() {
@@ -23,8 +23,7 @@ build() {
export GOPATH="$srcdir/gopath"
cd "$_gopkg"
LDFLAGS+=" -X github.com/VirusTotal/vt-cli/cmd.Version=${pkgver}"
- go build -gcflags "all=-trimpath=${GOPATH}" \
- -asmflags "all=-trimpath=${GOPATH}" \
+ go build -trimpath \
-ldflags "-extldflags=${LDFLAGS}" \
-buildmode=pie -o build/vt vt/main.go
}