summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthias Lisin2019-05-05 16:03:38 +0200
committerMatthias Lisin2019-05-05 16:03:38 +0200
commita3fc551232e705f8cc514f93f8b6d05ed7fdfad3 (patch)
treedc07e9320db298dc81d62182a3118c7abe8964aa /PKGBUILD
parentb8e9e17c6ff923f5ee6a822124f52395ae511638 (diff)
downloadaur-a3fc551232e705f8cc514f93f8b6d05ed7fdfad3.tar.gz
upgpkg: vt-cli 0.5.0-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 12 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6cf1767c47e5..2e05bf430b51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,32 @@
# Maintainer: Matthias Lisin <ml@visu.li
pkgname=vt-cli
pkgver=0.5.0
-pkgrel=1
+pkgrel=2
pkgdesc='VirusTotal Command Line Interface'
-arch=('any')
+arch=('i686' 'x86_64')
url='https://github.com/VirusTotal/vt-cli'
license=('Apache')
makedepends=('go' 'dep')
-provides=('vt-cli')
-conflicts=('vt-cli-bin' 'vt-cli-git')
-source=("${url}/archive/${pkgver}.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::${url}/archive/${pkgver}.tar.gz")
sha512sums=('fc37281c78349f0ef6d194c1ace9c36a7fc03a5dfd82d4da1d3176907b432c39c32ccb31d3f5da780fdd46e81a3eb7a6547f4d9385e3c2dc9ad5da6f77be7c52')
_gopkg=gopath/src/github.com/VirusTotal/"$pkgname"
prepare() {
- export GOPATH="$srcdir"/gopath
- mkdir -p gopath/src/github.com/VirusTotal
- ln -rTsf "$pkgname-$pkgver" "$_gopkg"
+ export GOPATH="$srcdir/gopath"
+ mkdir -p "${_gopkg%/*}"
+ ln -frs "$pkgname-$pkgver" "$_gopkg"
cd "$_gopkg"
dep ensure
}
build() {
- export GOPATH="$srcdir"/gopath
- LDFLAGS+=" -X=github.com/VirusTotal/vt-cli/cmd.Version=${pkgver}"
- cd gopath/src/github.com/VirusTotal/"$pkgname"
- go build -gcflags "all=-trimpath=${PWD}" \
- -asmflags "all=-trimpath=${PWD}" \
+ export GOPATH="$srcdir/gopath"
+ cd "$_gopkg"
+ LDFLAGS+=" -X github.com/VirusTotal/vt-cli/cmd.Version=${pkgver}"
+ go build -gcflags "all=-trimpath=${GOPATH}" \
+ -asmflags "all=-trimpath=${GOPATH}" \
-ldflags "-extldflags=${LDFLAGS}" \
- -o build/vt vt/main.go
-
+ -buildmode=pie -o build/vt vt/main.go
}
package() {