summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMikael Blomstrand2018-10-17 16:37:43 +0200
committerMikael Blomstrand2018-10-17 16:37:43 +0200
commit7040c6bc0c4fdf8256cf4a1356ff769174be5d37 (patch)
tree0cc655b5a9378191422cee03f60dbb9f53128e42 /PKGBUILD
downloadaur-7040c6bc0c4fdf8256cf4a1356ff769174be5d37.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..92a48f9c19d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Mikael Blomstrand <mbloms ÅT kth DÖT se>
+
+pkgname=vtable-dumper
+pkgver=1.2
+pkgrel=1
+pkgdesc="A tool to list content of virtual tables in a C++ shared library."
+arch=('i686' 'x86_64')
+url="https://github.com/lvc/vtable-dumper"
+license=('LGPL')
+depends=('libelf' 'gcc-libs')
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/lvc/${pkgname}/archive/${pkgver}.tar.gz)
+md5sums=('1b1e2bc09b0fe63abf01e1ad2526c40d')
+sha1sums=('2ae56500487a9073eddc1c7c1fcf7fd537c8984b')
+sha256sums=('6993781b6a00936fc5f76dc0db4c410acb46b6d6e9836ddbe2e3c525c6dd1fd2')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make install DESTDIR=${pkgdir} prefix=/usr
+}