summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Garfias2021-12-08 10:54:01 +0100
committerDavid Garfias2021-12-08 10:54:01 +0100
commit14eb34a5ef41765ed13a4bde2265b2d5744bf1d3 (patch)
tree643d300018872fb3966ece135605315fe653cd27 /PKGBUILD
parent3e163e1eb0d8e21854968119eaeceb7826146781 (diff)
downloadaur-14eb34a5ef41765ed13a4bde2265b2d5744bf1d3.tar.gz
fixed versioning
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 11 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6275998f4a0c..7d7772bc2621 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,9 @@
# Contributor: Lubosz Sarnecki <lubosz@gmail.com>
# Original package: Ionut Biru <ibiru@archlinux.org>
-_gitname=vte
-_realname=vte3
-pkgname=$_realname-git
+pkgname=vte3-git
-pkgver=0.67.0.5137.ba78631c
+pkgver=0.67.0.4.3e163e1
pkgrel=1
pkgdesc="Virtual Terminal Emulator widget for use with GTK3"
arch=('x86_64')
@@ -18,30 +16,27 @@ url="http://www.gnome.org"
depends=('gtk3' 'vte-common' 'glibc' 'pcre2')
provides=(vte3=$pkgver vte-common 'libvte-2.91.so')
-conflicts=($_realname vte-common)
+conflicts=(vte3 vte-common)
-source=("git+https://gitlab.gnome.org/GNOME/$_gitname.git")
+source=("git+https://gitlab.gnome.org/GNOME/vte.git")
md5sums=("SKIP")
+prepare() {
+ arch-meson vte build \
+ -D b_lto=false
+}
+
pkgver() {
- cd $srcdir
version=$(grep "\#define VERSION " build/config.h | sed 's/\#define VERSION //' | sed 's/\"//g')
- cd $_gitname
hash=$(git log --pretty=format:'%h' -n 1)
revision=$(git rev-list --count HEAD)
echo $version.$revision.$hash
}
-prepare() {
- cd $_gitname
-}
-
build() {
- arch-meson $_gitname build \
- -D b_lto=false
- meson compile -C build
+ ninja -C build
}
package() {
- meson install -C build --destdir "$pkgdir"
+ ninja install -C build
}