summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFelipe Contreras2020-12-06 19:42:14 -0600
committerFelipe Contreras2020-12-06 19:50:28 -0600
commit84ce92c955b2e4d55f966ab540c785c81d13e438 (patch)
tree6086d41ce22ba9dec514cfcffb5ec7dffbd8cf42 /PKGBUILD
parent4466f7230710b81bcb2b8e19a1adcae8f904745f (diff)
downloadaur-84ce92c955b2e4d55f966ab540c785c81d13e438.tar.gz
Add the patch that admins didn't want to address
Since Doug Newgard rejected it: https://bugs.archlinux.org/task/68868 Signed-off-by: Felipe Contreras <felipe.contreras@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7ae5a91cc32f..b508c49d8c9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,10 @@ license=(LGPL)
depends=(gtk3 pcre2 gnutls fribidi systemd-libs)
makedepends=(gobject-introspection vala git gtk-doc gperf meson)
_commit=62c4908953e3fea8e0771fa82212462157d46d4f # tags/0.62.1^0
-source=("git+https://gitlab.gnome.org/GNOME/vte.git#commit=$_commit")
-sha256sums=('SKIP')
+source=("git+https://gitlab.gnome.org/GNOME/vte.git#commit=$_commit"
+ fix-exit-regression.patch)
+sha256sums=('SKIP'
+ '582edbac0c92cb023a4c0a8f70cb74c85606c139ab8c8f83f6093a21e3033a5c')
depends+=(vte-common)
provides=("vte3=$pkgver" libvte-2.91.so)
@@ -23,6 +25,7 @@ pkgver() {
prepare() {
cd vte
+ patch -p1 -i "$srcdir/fix-exit-regression.patch"
}
build() {