summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEric Engestrom2019-10-08 23:27:06 +0100
committerEric Engestrom2019-10-08 23:27:38 +0100
commit78eaccd2ad3294a878c31be805cbf8a65c730b3a (patch)
treeb67f8b36b34b0f858a23cb3b001368875d420f64 /PKGBUILD
parent841b2d12027b504141af081ebf749257071f4fc6 (diff)
downloadaur-78eaccd2ad3294a878c31be805cbf8a65c730b3a.tar.gz
hack: get things building again after the upstream submodule move
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2fcf195ce9fa..2b02920a59c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,6 +12,9 @@ sha1sums=('bd4edf5510968bd5c9c2bce0deb4c048b7ddf966')
makedepends=(qt5-base)
depends=(vulkan-icd-loader qt5-base qt5-x11extras)
+#HACK: github doesn't package submodules, so we need to manually fetch the vulkan headers
+makedepends+=(git)
+
prepare() {
if [ -d build ]
then
@@ -20,6 +23,14 @@ prepare() {
return
fi
+ #HACK: github doesn't package submodules...
+ git clone --depth 1 https://github.com/KhronosGroup/Vulkan-Headers \
+ VulkanCapsViewer-$pkgver/Vulkan-Headers
+
+ #HACK: the last commit of 2.02 explicitely breaks the build; probably wasn't intended to be pushed out
+ sed 's#"/Vulkan-Headers/include"#"./Vulkan-Headers/include"#' \
+ -i VulkanCapsViewer-$pkgver/vulkanCapsViewer.pro
+
mkdir build
cd build
export PREFIX="$pkgdir"