summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMagnus Boman2022-10-25 18:21:27 +0200
committerMagnus Boman2022-10-25 18:21:27 +0200
commita7c965b5d6ededfcf9536809053551824d486d49 (patch)
tree0fa3cc3fa70e99174a1ee88023725ce234ac7485 /PKGBUILD
parentd496799e917280822c8fccf16ae4f1d1e1797faf (diff)
downloadaur-a7c965b5d6ededfcf9536809053551824d486d49.tar.gz
upgpkg: vulkan-icd-loader-git 1.3.231.r12.gceabdb1fa-1
Remove patch as it was merged.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 3 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6142cf2e631f..8db823c9a3ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Laurent Carlier <lordheavym@gmail.com>
pkgname=vulkan-icd-loader-git
-pkgver=1.3.231.r4.g9cd0dc8cd
+pkgver=1.3.231.r12.gceabdb1fa
pkgrel=1
arch=(x86_64)
pkgdesc='Vulkan Installable Client Driver (ICD) Loader (git)'
@@ -13,19 +13,13 @@ depends=(glibc)
optdepends=('vulkan-driver: packaged vulkan driver') # vulkan-driver: vulkan-intel/vulkan-radeon/nvidia-utils/....
provides=("${pkgname%-git}" libvulkan.so)
conflicts=("${pkgname%-git}")
-source=("${pkgname%-git}"::git+https://github.com/KhronosGroup/Vulkan-Loader.git
- https://github.com/KhronosGroup/Vulkan-Loader/commit/456946a138c219941f321f2db5d519846b55847b.patch)
-sha256sums=('SKIP'
- '11220d7d9841f952a65ce5ffd10700f4c29c66e1cc11a28a9b28b0572b6d3e89')
+source=("${pkgname%-git}"::git+https://github.com/KhronosGroup/Vulkan-Loader.git)
+sha256sums=('SKIP')
pkgver() {
git -C "${pkgname%-git}" describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- patch --directory="${pkgname%-git}" --forward --strip=1 --input="${srcdir}/456946a138c219941f321f2db5d519846b55847b.patch"
-}
-
build() {
cmake -B build -S "${pkgname%-git}" \
-DCMAKE_INSTALL_PREFIX=/usr \