summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorManuel Reimer2019-12-23 17:23:50 +0100
committerManuel Reimer2019-12-23 17:23:50 +0100
commit57dc7150f9b989c0941678136aa1de0f4f9aaacd (patch)
tree830b1b53d669d6bf4afcd33a4b0063c7ce607ca4 /PKGBUILD
downloadaur-57dc7150f9b989c0941678136aa1de0f4f9aaacd.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ca378f2bdb5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Manuel Reimer <manuel.reimer@gmx.de>
+pkgname=w_scan2
+pkgver=1.0.5
+pkgrel=1
+pkgdesc="w_scan fork (Small channel scan tool for vdr)"
+url="https://github.com/stefantalpalaru/w_scan2"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('GPL2')
+depends=('gcc-libs' 'glibc')
+#gcc-libs is somehow needed on arm architecture
+source=("$pkgname-$pkgver.tar.gz::https://github.com/stefantalpalaru/w_scan2/archive/$pkgver.tar.gz")
+sha256sums=('0492d6e03588f34c6eea84fb3a5a41409e427fb9f71c8ecbfd9cabe2ce2e3c93')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+}