summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBooloki2018-12-03 19:20:45 +0100
committerBooloki2018-12-03 19:20:45 +0100
commite62c0402fc0d3edd441c9f42fdec06de17edde0d (patch)
tree1b4fd6e87e63747629ed24b5665812d95d55c210 /PKGBUILD
downloadaur-e62c0402fc0d3edd441c9f42fdec06de17edde0d.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..998e955bc94b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# $Id$
+# Maintainer : Nicolas Perrin <booloki@lokizone.net>
+
+pkgname=wait-for-it
+pkgver=0.0+git20181104
+pkgrel=1
+pkgdesc="Script that will wait on the availability of a host and TCP port"
+arch=(any)
+license=('MIT')
+url="https://github.com/vishnubob/wait-for-it"
+source=('wait-for-it::git://github.com/vishnubob/wait-for-it.git'
+ 'wait-for-it.8.gz')
+sha256sums=('SKIP'
+ '36770f1d186b8be51a20d957ed2957ec1f8e16e772c37fe56942d4d57cc87de1')
+
+package() {
+ install -D -m644 "wait-for-it.8.gz" "${pkgdir}/usr/share/man/man8/wait-for-it.8.gz"
+
+ cd "${srcdir}/${pkgname}"
+ install -D -m755 "wait-for-it.sh" "${pkgdir}/usr/bin/wait-for-it"
+ install -D -m644 "README.md" "${pkgdir}/usr/share/doc/wait-for-it/README"
+}