summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGaoyang Zhang2021-12-20 17:29:39 +0800
committerGaoyang Zhang2021-12-20 17:29:39 +0800
commit8b2dab7667f6dfe4c7d18d3da886e485b77ae09d (patch)
treea5177ebdb333fdbf44eb6ffec80baf2c082d696a /PKGBUILD
downloadaur-8b2dab7667f6dfe4c7d18d3da886e485b77ae09d.tar.gz
chore: initialize with version 1.30.3
Signed-off-by: Gaoyang Zhang <gy@blurgy.xyz>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b26d5f8c6121
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Gaoyang Zhang <gy@blurgy.xyz>
+pkgname=wakapi-bin
+pkgver=1.30.3
+pkgrel=1
+epoch=
+pkgdesc="A minimalist, self-hosted WakaTime-compatible backend for coding statistics"
+arch=("x86_64")
+url="https://github.com/muety/wakapi"
+license=('GPL-3.0')
+groups=()
+depends=()
+makedepends=(
+ unzip
+)
+checkdepends=()
+optdepends=()
+provides=("wakapi")
+conflicts=("wakapi")
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(
+ "https://github.com/muety/wakapi/releases/download/${pkgver}/wakapi_linux_amd64.zip"
+ "https://raw.githubusercontent.com/muety/wakapi/master/LICENSE"
+)
+sha256sums=(
+ "6f6d45c7b7e04506d1de808caed34a722d81fad3ad8d65430abb39fcf8f85bd3"
+ "5341037102b6fb387ebcb7b1c8bff1aeda5f7be94f20ab1c9f6449094cfb0f56"
+)
+noextract=()
+validpgpkeys=()
+
+package() {
+ unzip -o wakapi_linux_amd64.zip
+ install -Dm755 "wakapi" "$pkgdir/usr/bin/wakapi"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/wakapi/LICENSE"
+ install -Dm644 "config.yml" "$pkgdir/etc/wakapi/config.yml"
+}