summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatMoul2023-01-14 20:18:41 +0100
committerMatMoul2023-01-14 20:18:41 +0100
commita75c1f1f17ae3516985f6230bd05eb4d4dca7ff3 (patch)
treeeab1bcb5867366ac325ac4bcd329db5108a53d00 /PKGBUILD
parentab6bb054d9e5eb394afb6abf174057a25b90e281 (diff)
downloadaur-a75c1f1f17ae3516985f6230bd05eb4d4dca7ff3.tar.gz
Version 2.8.0.11-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 10 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 40ffcc5f1cdd..9930895e8fa5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,25 @@
-
-# Maintainer: matmoul <matmoul at the google email domain which is .com>
-# Contributor: enihcam <nanericwang at the google email domain which is .com>
-# Contributor: Arun <cute.tec at the google email domain which is .com>
+# Maintainer: MatMoul <matmoul at the google email domain which is .com>
+
+_githubuser=Azure
+_githubrepo=WALinuxAgent
+_pkgtagname=v2.8.0.11
pkgname=walinuxagent
-_pkgname=WALinuxAgent
pkgver=2.8.0.11
pkgrel=1
-pkgdesc="Microsoft Azure Linux Agent"
+pkgdesc='Microsoft Azure Linux Agent'
arch=('any')
-url="https://github.com/Azure/WALinuxAgent"
+url="https://github.com/${_githubuser}/${_githubrepo}"
license=('Apache')
depends=('python' 'python-distro' 'openssh' 'openssl' 'parted' 'net-tools')
makedepends=('python-setuptools')
-checkdepends=()
-optdepends=()
install=${pkgname}.install
-provides=("walinuxagent")
-backup=("etc/waagent.conf")
-options=()
-changelog=
-source=("https://github.com/Azure/WALinuxAgent/archive/v${pkgver}.tar.gz")
+backup=('etc/waagent.conf')
+source=("${_githubrepo}::https://github.com/${_githubuser}/${_githubrepo}/archive/refs/tags/${_pkgtagname}.tar.gz")
sha256sums=('dbb36994d1df610943cd49609a49bf4ec6524520d88709891d282cec3607a31b')
package() {
- cd "$_pkgname-$pkgver"
+ cd "${_githubrepo}-${pkgver}"
python setup.py install --root="$pkgdir" --prefix="/usr" --optimize=1
install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
}