summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTuxx2024-04-24 01:38:40 +0200
committerTuxx2024-04-24 01:38:40 +0200
commitc8d361ad6b74531d8286b2dce30203f158eefbfc (patch)
treeb65495fa4d092868761d1b93a22e0beaeb71ed4d /PKGBUILD
parent9c693284bea2f4e669cc1bd5d9c533a5fc8fb910 (diff)
downloadaur-wallock-git.tar.gz
Removed debug package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7fa434628d10..b4ca10375a48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tuxx <tuxx@danktank.nl>
# Contributor: Tuxx <tuxx@danktank.nl>
pkgname=wallock-git
-pkgver=r22.651c017
+pkgver=r41.6bf9f5e
pkgrel=1
pkgdesc="wallock is a wallpaper and lock screen that enables macos like lock screens and wallapers on wayland. It is designed to work with wlroots based wayland compositors (sway, hyprland, etc..)."
arch=(any)
@@ -14,7 +14,7 @@ provides=("${pkgname}")
conflicts=("${pkgname}")
replaces=()
backup=()
-options=()
+options=('!debug')
install=
source=(git+"https://github.com/dpayne/wallock")
noextract=()
@@ -23,16 +23,15 @@ md5sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
-
}
build() {
- cd "$srcdir/${pkgname%-git}"
+ cd "$srcdir/${pkgname%-git}"
cmake -DCMAKE_BUILD_TYPE=Release -B build
cmake --build build
}
package() {
- cd "$srcdir/${pkgname%-git}"
+ cd "$srcdir/${pkgname%-git}"
DESTDIR="$pkgdir" cmake --install build
}