summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Filonenko2017-08-22 23:20:21 +0300
committerAlex Filonenko2017-08-22 23:21:21 +0300
commit6cdc77b1ff94bab48d985fce038d0fff9aa88661 (patch)
treef47ebbf974f90576e78454353c3b7246c0484ef8 /PKGBUILD
downloadaur-6cdc77b1ff94bab48d985fce038d0fff9aa88661.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abb90c1df018
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Oleksii Filonenko <filalex77@gmail.com>
+pkgname=wallsplash
+pkgver=0.1
+pkgrel=2
+pkgdesc="Set unsplash wallpapers with colorschemes"
+url="https://github.com/filalex77/wallsplash/"
+license=('GPL')
+arch=('x86_64' 'x86')
+depends=('feh' 'wal-git' 'nodejs-unsplash-wallpaper')
+makedepends=('nodejs' 'npm')
+optdepends=()
+source=("$pkgname-$pkgver.tar.gz")
+sha1sums=(SKIP)
+
+package() {
+ install -d "$pkgdir/usr/bin"
+ cd "$pkgname-$pkgver"
+ install -Dm644 wallsplash \
+ "$pkgdir/usr/bin/wallsplash"
+}