summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJU120002023-12-31 00:08:59 -0800
committerJU120002023-12-31 00:08:59 -0800
commite57d573129a6b99e745c174a4e4cebfae36fccbe (patch)
tree99187e7e200a65391bdf9386572b44be184d6f73 /PKGBUILD
downloadaur-e57d573129a6b99e745c174a4e4cebfae36fccbe.tar.gz
Initial upload of wallust-git to AUR.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3bec349f7be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: James Williams <jowilliams12000 at gmail dot com>
+pkgname=wallust-git
+pkgver=2.9.0.r0.g53799e0
+pkgrel=1
+pkgdesc="generate colors from an image"
+arch=('any')
+url="https://codeberg.org/explosion-mental/wallust"
+license=('custom:MIT')
+makedepends=('cargo' 'git')
+source=("$pkgname::git+$url#branch=master")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname"
+ echo "$pkgdir"
+ install -Dm755 target/release/wallust -t "${pkgdir}/usr/bin"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/wallust/LICENSE"
+}