summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAleksandar Trifunovic2018-09-28 14:53:05 +0200
committerAleksandar Trifunovic2018-09-28 14:53:05 +0200
commit4289bca83c233c8ca75425d42f6e5a44bcc3b467 (patch)
tree3dc791972629978c6c92dd7586e9a07b2f44c336 /PKGBUILD
parenta4db01101ea32e28ec473c3d89d6c984cdf6ec2f (diff)
downloadaur-4289bca83c233c8ca75425d42f6e5a44bcc3b467.tar.gz
2018.09.24.00
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 27 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a52892363196..3af4a8300d53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,39 @@
-# Maintainer: Daichi Shinozaki <dsdseg@gmail.com>
+# Maintainer: Aleksandar Trifunović <akstrfn at gmail dot com>
+# Contributor: Daichi Shinozaki <dsdseg at gmail dot com>
+
pkgname=wangle
-pkgver=2017.03.20.00
+pkgver=2018.09.24.00
pkgrel=1
-pkgdesc="A full featured, high performance C++ futures implementation"
+pkgdesc="A full featured, high performance C++ futures implementation."
arch=('i686' 'x86_64')
url="https://github.com/facebook/wangle"
license=('Apache')
-depends=('folly' 'boost' 'boost-libs')
-makedepends=('cmake' 'gflags' 'gtest' 'google-glog')
-options=('!emptydirs' 'staticlibs')
-source=("https://github.com/facebook/$pkgname/archive/v${pkgver}.tar.gz")
-md5sums=('36519236badf050403f89f3a0b422b64')
+depends=('folly' 'boost-libs')
+makedepends=('cmake' 'gflags' 'gtest' 'google-glog' 'boost')
+source=("$url/archive/v${pkgver}.tar.gz")
+sha256sums=('f51bb3668b526eead3861f988cc4028e5ddd13c830aa0e843acaa01eff8c78f6')
+
+prepare() {
+ cd "$pkgname-$pkgver/$pkgname"
+ cmake -H. -Bbuild \
+ -DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
+ -DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS}" \
+ -DCMAKE_EXE_LINKER_FLAGS:STRING="${LDFLAGS}" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+}
build() {
- cd "$pkgname-$pkgver/$pkgname"
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release .
- make
+ cd "$pkgname-$pkgver/$pkgname"
+ cmake --build build
}
-#check() {
-# cd "$pkgname-$pkgver/$pkgname"
-# ctest
-#}
+check() {
+ cd "$pkgname-$pkgver/$pkgname"
+ cmake --build build -- test
+}
package() {
- cd "$pkgname-$pkgver/$pkgname"
- make DESTDIR=$pkgdir install
+ cd "$pkgname-$pkgver/$pkgname"
+ cmake --build build -- DESTDIR=$pkgdir install
}
-