summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkiasoc52022-01-17 02:14:54 -0500
committerSpencer Skylar Chan2022-01-17 02:22:20 -0500
commitbbfe62946301395a22adcc7e8c41d1f2976b562e (patch)
tree5b1f9ea2e99652d7f5b3bcaa57bf44f5dcb0c96c /PKGBUILD
downloadaur-bbfe62946301395a22adcc7e8c41d1f2976b562e.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a01bf12c7c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: kiasoc5 <kiasoc5 at tutanota dot com>
+
+pkgname=wapanel
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Simple panel/status bar/task bar for your custom stacking Wayland-based desktop."
+arch=('x86_64')
+url="https://github.com/Firstbober/wapanel"
+license=('MIT')
+depends=('gtk-layer-shell' 'gtk3' 'wayland' 'wayland-protocols' 'libpulse' 'xdg-utils' 'wlroots')
+makedepends=('meson' 'toml11' 'pkgconf')
+source=(https://github.com/Firstbober/${pkgname}/archive/refs/tags/${pkgver}.tar.gz)
+sha256sums=('4f2f11f0d001b4507b5b1dc6622df68a9e786f590cabf603bc5a3b296039f0a5')
+
+build() {
+ arch-meson "$pkgname-$pkgver" build
+ meson compile -C build
+}
+
+package() {
+ meson install -C build --destdir "$pkgdir"
+ install -Dm644 "$pkgname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}