summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2023-10-16 13:29:26 -0600
committerMark Wagie2023-10-16 13:29:26 -0600
commit222fa231219d0a2c734381df7857dcb37e2cf8f0 (patch)
tree0bca6522b84cf4e0d6ce8fc1a5f5f430b117559b /PKGBUILD
parent7534d07a5a322cc3f690947d14f4c0bc28f1de29 (diff)
downloadaur-222fa231219d0a2c734381df7857dcb37e2cf8f0.tar.gz
update build deps & Meson options
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a978d092cc7c..83f40e0e5357 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
# Contributor: Kyle Laker <kyle@laker.email>
pkgname=warpinator-git
_desktop_id=org.x.Warpinator
-pkgver=1.4.3.r2.g1889a48
+pkgver=1.6.4.r20.g10eb1e5a
pkgrel=1
pkgdesc="Share files across the LAN"
arch=('any')
@@ -12,7 +12,7 @@ depends=('gtk3' 'libnm' 'python-cairo' 'python-cryptography' 'python-gobject'
'python-grpcio' 'python-netifaces' 'python-packaging' 'python-protobuf'
'python-pynacl' 'python-setproctitle' 'python-setuptools' 'python-zeroconf'
'python-xapp' 'xapps')
-makedepends=('git' 'meson' 'polkit')
+makedepends=('cython' 'git' 'meson' 'polkit')
checkdepends=('appstream-glib')
optdepends=('ufw: Configure firewall rules')
provides=("${pkgname%-git}")
@@ -34,7 +34,9 @@ prepare() {
}
build() {
- arch-meson "${pkgname%-git}" build -Dbundle-zeroconf=false
+ arch-meson "${pkgname%-git}" build \
+ -Dbundle-zeroconf=false \
+ -Dbundle-grpc=false
meson compile -C build
}