summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2023-11-30 12:03:51 -0700
committerMark Wagie2023-11-30 12:03:51 -0700
commit63541e2030c5098a135cc8467fb9f006482c470e (patch)
tree461e93516c2a724fba0a4f5a93975a3c1782b1f3 /PKGBUILD
parent222fa231219d0a2c734381df7857dcb37e2cf8f0 (diff)
downloadaur-63541e2030c5098a135cc8467fb9f006482c470e.tar.gz
add landlock dep
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 21 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83f40e0e5357..ae5e59178646 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,30 @@
# Contributor: Kyle Laker <kyle@laker.email>
pkgname=warpinator-git
_desktop_id=org.x.Warpinator
-pkgver=1.6.4.r20.g10eb1e5a
+pkgver=1.8.0.r0.gc3da064c
pkgrel=1
pkgdesc="Share files across the LAN"
arch=('any')
url="https://github.com/linuxmint/warpinator"
license=('GPL3')
-depends=('gtk3' 'libnm' 'python-cairo' 'python-cryptography' 'python-gobject'
- 'python-grpcio' 'python-netifaces' 'python-packaging' 'python-protobuf'
- 'python-pynacl' 'python-setproctitle' 'python-setuptools' 'python-zeroconf'
- 'python-xapp' 'xapps')
+depends=(
+ 'gtk3'
+ 'libnm'
+ 'python-cairo'
+ 'python-cryptography'
+ 'python-gobject'
+ 'python-grpcio'
+ 'python-landlock'
+ 'python-netifaces'
+ 'python-packaging'
+ 'python-protobuf'
+ 'python-pynacl'
+ 'python-setproctitle'
+ 'python-setuptools'
+ 'python-zeroconf'
+ 'python-xapp'
+ 'xapps'
+)
makedepends=('cython' 'git' 'meson' 'polkit')
checkdepends=('appstream-glib')
optdepends=('ufw: Configure firewall rules')
@@ -36,7 +50,8 @@ prepare() {
build() {
arch-meson "${pkgname%-git}" build \
-Dbundle-zeroconf=false \
- -Dbundle-grpc=false
+ -Dbundle-grpc=false \
+ -Dbundle-landlock=false
meson compile -C build
}