summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTest User2020-03-07 08:01:23 -0700
committerTest User2020-03-07 08:01:23 -0700
commit7ce522669dc48585ec0a3dbdb1232873124c63aa (patch)
treeb71369ca815e78a731b56d47741666e795b0828f /PKGBUILD
parentcc7dfeadb94cc25de27c17373563c621d18e1751 (diff)
downloadaur-7ce522669dc48585ec0a3dbdb1232873124c63aa.tar.gz
fix autostart desktop Exec, add desktop file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 394402b45170..68cb67879c24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Kyle Laker <kyle@laker.email>
# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=warpinator-git
-pkgver=r58.32feb06
+pkgver=r73.10a969f
pkgrel=1
pkgdesc="Share files across the LAN"
arch=('x86_64')
@@ -13,8 +13,10 @@ makedepends=('git' 'meson' 'python-grpcio-tools')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}" 'lm-warp')
replaces=('lm-warp')
-source=('git+https://github.com/linuxmint/warp.git')
-sha512sums=('SKIP')
+source=('git+https://github.com/linuxmint/warp.git'
+ 'warp.desktop')
+sha256sums=('SKIP'
+ '0e74a83e7d384609e40dc6355a2e392c9e0bb4d44a6e1a4850a7b750b093daa5')
pkgver() {
cd "$srcdir/warp"
@@ -39,4 +41,8 @@ package() {
# Binary name conflicts with haskell-wai-app-static
mv "$pkgdir/usr/bin/warp" "$pkgdir/usr/bin/${pkgname%-git}"
+
+ sed -i 's/Exec=warp/Exec=warpinator/g' "$pkgdir/etc/xdg/autostart/warp.desktop"
+
+ install -Dm644 "$srcdir/warp.desktop" -t "$pkgdir/usr/share/applications"
}