summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2021-06-17 18:27:28 -0600
committerMark Wagie2021-06-17 18:27:28 -0600
commit7da438997490fc70bdfa16b3c5542148c951761b (patch)
tree8a5a039779676a76f39e61a137ea3a4eda7aff11 /PKGBUILD
parentcd55f27c05d30813657fae6ebc02ec91aa1f0c60 (diff)
downloadaur-7da438997490fc70bdfa16b3c5542148c951761b.tar.gz
adjust build deps
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 37a300ea448f..f72bfc18fcc9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: Kyle Laker <kyle@laker.email>
pkgname=warpinator-git
-pkgver=1.2.0.r1.g471c893
-pkgrel=3
+pkgver=1.2.2.r0.gc066c5f
+pkgrel=1
pkgdesc="Share files across the LAN"
arch=('any')
url="https://github.com/linuxmint/warpinator"
@@ -10,9 +10,8 @@ license=('GPL3')
depends=('gtk3' 'libnm' 'python-cryptography' 'python-gobject' 'python-grpcio'
'python-netaddr' 'python-netifaces' 'python-protobuf' 'python-pynacl'
'python-setproctitle' 'python-zeroconf' 'python-xapp' 'xapps')
-makedepends=('git' 'meson' 'gobject-introspection')
-optdepends=('polkit: Open a firewall port'
- 'ufw: Configure firewall rules')
+makedepends=('git' 'meson' 'polkit')
+optdepends=('ufw: Configure firewall rules')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=('git+https://github.com/linuxmint/warpinator.git')
@@ -36,6 +35,11 @@ build() {
meson compile -C build
}
+# No tests defined
+#check() {
+# meson test -C build --print-errorlogs
+#}
+
package() {
DESTDIR="$pkgdir" meson install -C build
}