summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2020-03-22 19:53:17 -0600
committerMark Wagie2020-03-22 19:53:17 -0600
commit9c42112e207875ea53bf08cd3c21c2c613add082 (patch)
tree23e982fee588b77226b88f58cec2af23e7237dd0 /PKGBUILD
parentb7ae81347cb16bcced8807c29c651108cb9c74f2 (diff)
downloadaur-9c42112e207875ea53bf08cd3c21c2c613add082.tar.gz
upstream changes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 704fefab6643..2a306c50f8d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,20 @@
# Maintainer: Kyle Laker <kyle@laker.email>
# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=warpinator-git
-pkgver=r78.8e3d9f9
+pkgver=r119.bc21860
pkgrel=1
pkgdesc="Share files across the LAN"
arch=('x86_64')
url="https://github.com/linuxmint/warp"
-license=('GPL2')
+license=('GPL3')
depends=('gtk3' 'python-gobject' 'python-grpcio' 'python-protobuf' 'python-setproctitle'
'python-zeroconf' 'python-xapp' 'xapps')
makedepends=('git' 'meson' 'python-grpcio-tools' 'gobject-introspection')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}" 'lm-warp')
replaces=('lm-warp')
-source=('git+https://github.com/linuxmint/warp.git'
- 'warp.desktop')
-sha256sums=('SKIP'
- '0e74a83e7d384609e40dc6355a2e392c9e0bb4d44a6e1a4850a7b750b093daa5')
+source=('git+https://github.com/linuxmint/warp.git')
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/warp"
@@ -42,7 +40,7 @@ package() {
# Binary name conflicts with haskell-wai-app-static
mv "$pkgdir/usr/bin/warp" "$pkgdir/usr/bin/${pkgname%-git}"
- sed -i 's/Exec=warp/Exec=warpinator/g' "$pkgdir/etc/xdg/autostart/warp.desktop"
-
- install -Dm644 "$srcdir/warp.desktop" -t "$pkgdir/usr/share/applications"
+ sed -i 's/Exec=warp/Exec=warpinator/g' \
+ "$pkgdir/etc/xdg/autostart/warp-autostart.desktop" \
+ "$pkgdir/usr/share/applications/warp.desktop"
}