summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2023-12-01 08:45:39 -0700
committerMark Wagie2023-12-01 08:45:39 -0700
commita9a5e8634492e3e6ea5dd59e47dbd29ef70aec6d (patch)
tree811f46b94af8d67191d5eb35789329a24de9b2c7 /PKGBUILD
parentcf0bacfd99fbc94cfe0f7de8f194b001ae7106dc (diff)
downloadaur-a9a5e8634492e3e6ea5dd59e47dbd29ef70aec6d.tar.gz
minor PKGBUILD improvements
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dc7ba6080da7..3a0ee3017270 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -36,12 +36,12 @@ source=('git+https://github.com/linuxmint/warpinator.git')
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
git describe --long --tags --exclude master* | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
# Fix hard-coded libexec dir
find . -type f -exec sed -i 's/libexec/lib/g' {} \;
@@ -49,7 +49,7 @@ prepare() {
}
build() {
- arch-meson "${pkgname%-git}" build \
+ arch-meson "${pkgname%-git}" build \
-Dbundle-zeroconf=false \
-Dbundle-grpc=false \
-Dbundle-landlock=false
@@ -59,7 +59,7 @@ build() {
check() {
desktop-file-validate "build/data/${_desktop_id}.desktop"
- desktop-file-validate "$srcdir/${pkgname%-git}/data/${pkgname%-git}-autostart.desktop"
+ desktop-file-validate "${pkgname%-git}/data/${pkgname%-git}-autostart.desktop"
appstream-util validate --nonet "build/data/${_desktop_id}.appdata.xml"
}