summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTest User2020-04-13 10:45:45 -0600
committerTest User2020-04-13 10:45:45 -0600
commitab9321a3e5bf1e21abc6f5ec6df2856c36e8499c (patch)
tree76f6b2085a658c0316b101f127d4bdf9c54b06d9 /PKGBUILD
parent6deb65bd102170a76b58d2ff8e1089df61fe068b (diff)
downloadaur-ab9321a3e5bf1e21abc6f5ec6df2856c36e8499c.tar.gz
upstream changes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 3 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 797e65d1b7b2..58d60b3104b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Kyle Laker <kyle@laker.email>
# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=warpinator-git
-pkgver=0.0.1.r135.596d88f
+pkgver=0.0.1.r137.de5bd0a
pkgrel=1
pkgdesc="Share files across the LAN"
arch=('x86_64')
@@ -29,7 +29,8 @@ prepare() {
# Fix hard-coded libexec dir
sed -i 's/libexec/lib/g' \
- bin/warp install-scripts/meson_generate_and_install_protobuf_files.py
+ "bin/${pkgname%-git}" \
+ install-scripts/meson_generate_and_install_protobuf_files.py
}
build() {
@@ -39,11 +40,4 @@ build() {
package() {
DESTDIR="$pkgdir" ninja -C build install
-
- # Binary name conflicts with haskell-wai-app-static
- mv "$pkgdir/usr/bin/warp" "$pkgdir/usr/bin/${pkgname%-git}"
-
- sed -i 's/Exec=warp/Exec=warpinator/g' \
- "$pkgdir/etc/xdg/autostart/warp-autostart.desktop" \
- "$pkgdir/usr/share/applications/warp.desktop"
}