summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2020-03-03 17:42:45 -0700
committerMark Wagie2020-03-03 17:42:45 -0700
commitada56f3007c129ee7ecccab885a745299766ec07 (patch)
tree4287f6f9465d78d7838ae392153c982feeae8e38 /PKGBUILD
parent96f837189f23ce55a15bc7abaa0c1fa4ce8b03cc (diff)
downloadaur-ada56f3007c129ee7ecccab885a745299766ec07.tar.gz
update dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 24 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 26777ed3af03..394402b45170 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,42 @@
# Maintainer: Kyle Laker <kyle@laker.email>
-# Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
-
+# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=warpinator-git
-pkgver=r42.6f44410
-pkgrel=2
-pkgdesc="Share files across the LAN by Linux Mint"
-arch=("x86_64")
+pkgver=r58.32feb06
+pkgrel=1
+pkgdesc="Share files across the LAN"
+arch=('x86_64')
url="https://github.com/linuxmint/warp"
-# License file is missing from the root of the repository; however, GPL-2+ is given in the
-# debian/control file: https://github.com/linuxmint/warp/blob/master/debian/copyright
-license=("GPL")
-depends=("pygobject-devel" \
- "python-setproctitle" \
- "python-zeroconf" \
- "python-xapp" \
- "xapps" \
- "python-grpcio" \
- "python-grpcio-tools")
-makedepends=("git" "meson")
+license=('GPL2')
+depends=('gtk3' 'python-gobject' 'python-grpcio' 'python-protobuf' 'python-setproctitle'
+ 'python-zeroconf' 'python-xapp' 'xapps')
+makedepends=('git' 'meson' 'python-grpcio-tools')
provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}" "haskell-wai-app-static" "lm-warp-git" "warp-git")
-source=("git+${url}.git")
+conflicts=("${pkgname%-git}" 'lm-warp')
+replaces=('lm-warp')
+source=('git+https://github.com/linuxmint/warp.git')
sha512sums=('SKIP')
pkgver() {
- cd "$srcdir/warp"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/warp"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- cd "$srcdir/warp"
+ cd "$srcdir/warp"
- # Fix hard-coded libexec dir in main warp script
- sed -i 's/libexec/lib/g' bin/warp
- sed -i 's/libexec/lib/g' install-scripts/meson_generate_and_install_protobuf_files.py
+ # Fix hard-coded libexec dir
+ sed -i 's/libexec/lib/g' \
+ bin/warp install-scripts/meson_generate_and_install_protobuf_files.py
}
build() {
- arch-meson warp build
- ninja -C build
+ arch-meson warp build
+ ninja -C build
}
package() {
- DESTDIR="$pkgdir" ninja -C build install
+ DESTDIR="$pkgdir" ninja -C build install
+
+ # Binary name conflicts with haskell-wai-app-static
+ mv "$pkgdir/usr/bin/warp" "$pkgdir/usr/bin/${pkgname%-git}"
}