summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2022-07-02 08:54:52 -0600
committerMark Wagie2022-07-02 08:54:52 -0600
commitf4a9bda00dd4ffe6b781f82ed2f3fa0e265afc75 (patch)
tree52b252a6bd4ae32cd234bf1783c66e4e68ca22fc /PKGBUILD
parent1ac4c9da55f592c09bce64e1452849d46554171d (diff)
downloadaur-f4a9bda00dd4ffe6b781f82ed2f3fa0e265afc75.tar.gz
adjust dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83ed55bc3ea5..3279446ee6e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
# Contributor: Kyle Laker <kyle@laker.email>
pkgname=warpinator-git
_desktop_id=org.x.Warpinator
-pkgver=1.2.4.r9.gc55eadc
+pkgver=1.2.12.r0.gba80311
pkgrel=1
pkgdesc="Share files across the LAN"
arch=('any')
url="https://github.com/linuxmint/warpinator"
license=('GPL3')
-depends=('gtk3' 'lshw' 'python-cryptography' 'python-gobject' 'python-grpcio'
- 'python-netaddr' 'python-netifaces' 'python-protobuf' 'python-pynacl'
- 'python-setproctitle' 'python-setuptools' 'python-zeroconf' 'python-xapp' 'xapps')
+depends=('gtk3' 'python-cryptography' 'python-gobject' 'python-grpcio'
+ 'python-netifaces' 'python-packaging' 'python-protobuf' 'python-pynacl'
+ 'python-setproctitle' 'python-zeroconf' 'python-xapp' 'xapps')
makedepends=('git' 'meson' 'polkit')
-checkdepends=('appstream')
+checkdepends=('appstream-glib')
optdepends=('ufw: Configure firewall rules')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -42,12 +42,9 @@ build() {
check() {
-
-# No tests defined
-# meson test -C build --print-errorlogs
-
- desktop-file-validate build/data/${_desktop_id}.desktop
- appstreamcli validate build/data/${_desktop_id}.appdata.xml
+ desktop-file-validate "build/data/${_desktop_id}.desktop"
+ desktop-file-validate "$srcdir/${pkgname%-git}/data/${pkgname%-git}-autostart.desktop"
+ appstream-util validate --nonet "build/data/${_desktop_id}.appdata.xml"
}
package() {