summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIan D. Scott2014-11-16 10:56:54 -0800
committerIan D. Scott2014-11-16 10:56:54 -0800
commit6c976cc67612c34a103adf99cd54c692ef34dec1 (patch)
treeb4a6e8e92e80a6d7080d4faf4276094ee2bb1f62 /PKGBUILD
downloadaur-6c976cc67612c34a103adf99cd54c692ef34dec1.tar.gz
Fix up and adopt warzone2100-git package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7ca3d6533ad1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Ian D. Scott <ian@perebruin.com>
+# Contributor: Lari Tikkanen <lartza@wippies.com>
+
+pkgname=warzone2100-git
+_gitname=warzone2100
+pkgver=master.SDL.r4032.g9cc1d33
+pkgrel=1
+pkgdesc="3D realtime strategy game on a future Earth (Git version)"
+arch=('i686' 'x86_64')
+url="http://wz2100.net/"
+license=('GPL')
+depends=('gettext' 'qt4' 'libtheora' 'openal' 'libvorbis' 'glew' 'physfs' 'quesoglc' 'ttf-dejavu')
+makedepends=('zip' 'unzip')
+provides=('warzone' 'warzone2100' 'warzone-svn' 'warzone2100-beta')
+conflicts=('warzone2100')
+source=('git://github.com/Warzone2100/warzone2100.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ ./autogen.sh
+ CCFLAGS= CXXFLAGS= ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ make DESTDIR="$pkgdir" install
+}