summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLartza2019-06-09 14:27:52 +0300
committerLartza2019-06-09 14:27:52 +0300
commit99bce34d0e2ae15ba0e93826f01be44f9e78c0c5 (patch)
treed10c8aef81ef2d2f66567ae54808f045950e69ca /PKGBUILD
parent1df982479b14cc801d1f9c40557fa43ac4078935 (diff)
downloadaur-99bce34d0e2ae15ba0e93826f01be44f9e78c0c5.tar.gz
Deps, submodules, remove qt5 backend
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 23 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 657736ea2ae1..dfb098a09670 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,30 @@
# Maintainer: Lari Tikkanen <lartza@wippies.com>
# Contributor: Ian D. Scott <ian@perebruin.com>
-# Use an alternative Qt backend to the SDL default. May not fully work, report issues upstream.
-_use_qt_backend="0"
-
pkgname=warzone2100-git
_gitname=warzone2100
-pkgver=r14106.52089c899
+pkgver=r14767.de9d91905
pkgrel=1
pkgdesc="3D realtime strategy game on a future Earth (Git version)"
arch=('i686' 'x86_64')
url="http://wz2100.net/"
license=('GPL')
depends=('qt5-script' 'sdl2' 'libtheora' 'openal' 'libvorbis' 'physfs' 'ttf-dejavu' 'glew' 'fribidi' 'xorg-xrandr')
-if [[ ${_use_qt_backend} == "1" ]]; then
- depends+=('qt5-x11extras')
-fi
-makedepends=('zip' 'unzip' 'git' 'gawk' 'flex' 'asciidoc')
+makedepends=('zip' 'unzip' 'git' 'asciidoc')
provides=('warzone' 'warzone2100' 'warzone-svn' 'warzone2100-beta')
conflicts=('warzone2100')
-source=('git+https://github.com/Warzone2100/warzone2100.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/Warzone2100/warzone2100.git'
+ 'git+https://github.com/g-truc/glm.git'
+ 'git+https://github.com/miniupnp/miniupnp.git'
+ 'git+https://github.com/BrianGladman/sha.git'
+ 'git+https://github.com/JuliaStrings/utf8proc.git'
+ 'git+https://github.com/nemtrif/utfcpp.git')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
cd "$_gitname"
@@ -29,17 +33,20 @@ pkgver() {
prepare() {
cd "$srcdir/$_gitname"
+
+ git submodule init
+ git config submodule.3rdparty/glm.url "$srcdir/glm"
+ git config submodule.3rdparty/miniupnp.url "$srcdir/miniupnp"
+ git config submodule.3rdparty/sha.url "$srcdir/sha"
+ git config submodule.3rdparty/utf8proc.url "$srcdir/utf8proc"
+ git config submodule.3rdparty/utfcpp.url "$srcdir/utfcpp"
+ git submodule update
}
build() {
cd "$srcdir/$_gitname"
./autogen.sh
-
- if [[ $_use_qt_backend == "1" ]]; then
- ./configure --prefix=/usr --with-backend=qt --disable-debug
- else
- ./configure --prefix=/usr --disable-debug
- fi
+ ./configure --prefix=/usr --disable-debug
make
}