summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Parrish2019-01-06 19:53:53 -0500
committerDavid Parrish2019-01-06 19:55:12 -0500
commit6e1801715c0fccf1fa9ee92c70c342dec5e66ab9 (patch)
treead41a75be30d0d4459d14ff3a1ba1af9ed6407b8 /PKGBUILD
parentc8bf81cdfd4b6029874677fd60b99ef3eb9fb063 (diff)
downloadaur-6e1801715c0fccf1fa9ee92c70c342dec5e66ab9.tar.gz
Add desktop launcher
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ed9e88d176a7..8ebbc19789af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=wasabi-wallet-bin
_pkgname=wasabi-wallet
pkgver=1.0.5
-pkgrel=1
+pkgrel=2
pkgdesc="Privacy focused, ZeroLink compliant Bitcoin wallet"
arch=('x86_64')
options=(!strip staticlibs)
@@ -13,9 +13,13 @@ conflicts=('wasabi-wallet')
source=(
"https://github.com/zkSNACKs/WalletWasabi/releases/download/v${pkgver}/WasabiLinux-${pkgver}.tar.gz"
"https://github.com/zkSNACKs/WalletWasabi/releases/download/v${pkgver}/WasabiLinux-${pkgver}.tar.gz.asc"
+ "wasabi.desktop"
+ "wasabi.png"
)
sha256sums=('c1d3ef22541a4565a9cc790daa90e550041d767cb9771abaea6399bb9a5d2f0c'
- 'SKIP')
+ 'SKIP'
+ '4d633e1b310eb2666e314b39a336031facd164f227a2ad595e8a0b8ba4b962ee'
+ '861064b9019ac8d0294d46c298dd2f552e078dc2d0f2b52ffb1e9e09a20278a3')
# Run gpg --keyserver pool.sks-keyservers.net --recv-keys B4B72266C47E075E
validpgpkeys=('21D7CA45565DBCCEBE45115DB4B72266C47E075E')
@@ -25,4 +29,8 @@ package() {
chown -R root:root "$pkgdir/opt/${_pkgname}"
install -d -m755 "${pkgdir}/usr/bin/"
ln -s "/opt/${_pkgname}/wassabee" "${pkgdir}/usr/bin/${_pkgname}"
+
+ # Install desktop launcher.
+ install -Dm644 wasabi.desktop "${pkgdir}/usr/share/applications/wasabi.desktop"
+ install -Dm644 wasabi.png "${pkgdir}/usr/share/pixmaps/wasabi.png"
}