summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkhai96_2021-01-06 08:23:31 +0700
committerkhai96_2021-01-06 08:23:31 +0700
commit6c8131b4fa59b64248d1f3e2e374f9266b874bce (patch)
tree755b53f309e7e8971394b7ece8c936a90fb2298e /PKGBUILD
parent5604d0e39ef874096079db3742e7f65f0b7228f3 (diff)
downloadaur-6c8131b4fa59b64248d1f3e2e374f9266b874bce.tar.gz
1.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD66
1 files changed, 49 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7f9ff7f73d5a..693e856d1ccc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,81 @@
# Maintainer: Hoàng Văn Khải <hvksmr1996@gmail.com>
pkgname='wasmer-bin'
-pkgver='0.17.1'
-pkgrel='0'
+pkgver='1.0.0'
+_shortver="${pkgver%.*}"
+_majorver="${_shortver%.*}"
+pkgrel='1'
pkgdesc='Universal WebAssembly runtime'
arch=('x86_64')
license=('MIT')
url='https://wasmer.io/'
depends=('bash')
-conflicts=('wasmer' 'wapm')
-provides=('wasmer' 'wapm')
+conflicts=(
+ 'wasmer'
+ 'wapm'
+)
+provides=(
+ 'wasmer'
+ 'wapm'
+ 'wasm.h'
+ 'wasmer_wasm.h'
+ 'wasmer.h'
+ 'wasmer.hh'
+ 'libwasmer.a'
+ "libwasmer.so.$pkgver"
+ "libwasmer.so.$_shortver"
+ "libwasmer.so.$_majorver"
+ "libwamser.so=$pkgver"
+)
source=(
"wasmer-linux-amd64-${pkgver}.tar.gz"::"https://github.com/wasmerio/wasmer/releases/download/${pkgver}/wasmer-linux-amd64.tar.gz"
"https://raw.githubusercontent.com/wasmerio/wasmer/${pkgver}/LICENSE"
- 'logo.sh'
)
sha512sums=(
'SKIP'
'SKIP'
- 'SKIP'
+)
+options=(
+ 'strip'
+ 'libtool'
+ 'staticlibs'
)
build() {
cd "$srcdir"
- # wapm completions
- ./bin/wapm completions bash >wapm-bash-completions
- ./bin/wapm completions zsh >wapm-zsh-completions
+ msg2 'Creating shell completion files for wapm...'
+ for shell in bash zsh fish; do
+ ./bin/wapm completions "$shell" >"wapm-$shell-completions"
+ done
}
package() {
cd "$srcdir"
- # display logo
- source logo.sh
+ msg2 'Installing executable commands...'
+ for name in wasmer wapm wax; do
+ install -Dm755 "bin/$name" "$pkgdir/usr/bin/$name"
+ done
- # executable commands
- install -Dm755 bin/wasmer "$pkgdir/usr/bin/wasmer"
- install -Dm755 bin/wapm "$pkgdir/usr/bin/wapm"
- ln -s wapm "$pkgdir/usr/bin/wax"
+ msg2 'Installing libraries...'
+ for name in wasm.h wasmer_wasm.h wasmer.h wasmer.hh; do
+ install -Dm644 "include/$name" "$pkgdir/usr/include/$name"
+ done
+ install -Dm644 lib/libwasmer.a "$pkgdir/usr/lib/libwasmer.a"
+ install -Dm755 lib/libwasmer.so "$pkgdir/usr/lib/libwasmer.so.$pkgver"
+ ln -s "libwasmer.so.$pkgver" "$pkgdir/usr/lib/libwasmer.so.$_shortver"
+ ln -s "libwasmer.so.$pkgver" "$pkgdir/usr/lib/libwasmer.so.$_majorver"
+ ln -s "libwasmer.so.$pkgver" "$pkgdir/usr/lib/libwasmer.so"
- # wapm completions
+ msg2 'Installing shell completion files for wapm...'
install -Dm644 wapm-bash-completions "$pkgdir/usr/share/bash-completion/completions/wapm"
install -Dm644 wapm-zsh-completions "$pkgdir/usr/share/zsh/site-functions/_wapm"
+ install -Dm644 wapm-fish-completions "$pkgdir/usr/share/fish/completions/wapm.fish"
- # license
+ msg2 'Installing license...'
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ msg2 'Installing documentation...'
+ install -Dm644 include/README.md "$pkgdir/usr/share/doc/$pkgname/wasmer-runtime-api.md"
}