summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDario Ostuni2019-12-29 02:05:53 +0100
committerDario Ostuni2019-12-29 02:05:53 +0100
commit9459fba0017cc9dde47cd154639a97877f7bbf71 (patch)
tree15c7d4c2229ee66a8ebdebcf6aae4ad0c9c3b2c0 /PKGBUILD
parent22ecff0216e71f4dcb560c32a0ba1859bc1fd58e (diff)
downloadaur-9459fba0017cc9dde47cd154639a97877f7bbf71.tar.gz
Fix compilation issue
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c70fd106c8ba..30cc9c665705 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,18 @@ pkgver=0.8.0
pkgrel=1
pkgdesc="Standalone JIT-style runtime for WebAssembly, using Cranelift"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
-url="https://github.com/CraneStation/wasmtime"
+url="https://github.com/bytecodealliance/wasmtime"
license=('APACHE2')
depends=()
makedepends=('cargo')
options=()
-source=("https://github.com/CraneStation/wasmtime/archive/v${pkgver}.tar.gz")
-sha384sums=('89005894df1d1a43a75636ed50637c8a5b9d22b17f67e4a3d9c26188d32fd76d7e10fbc3af7826648c5306318b670810')
+source=("${pkgname}-${pkgver}::git+https://github.com/bytecodealliance/wasmtime.git#tag=v${pkgver}")
+sha384sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ git submodule update --init --recursive
+}
build() {
cd "$srcdir/$pkgname-$pkgver"