summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArthur Vuillard2016-09-15 23:59:48 +0200
committerArthur Vuillard2016-09-15 23:59:48 +0200
commit6d9fa3a8a6e9082f15117230aae55db75000ce08 (patch)
tree3396a76261dd5902c1779227185063e71d17ebad /PKGBUILD
parent1bedd59b93148eb54783ff85aa28d2e81c157ab0 (diff)
downloadaur-6d9fa3a8a6e9082f15117230aae55db75000ce08.tar.gz
install as a service
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e80d92258ec5..68095ce3d6ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,6 +11,8 @@ license=('AGPLv3')
depends=('python-tornado' 'python-aioftp')
makedepends=('python-setuptools')
source=('git+https://gitlab.com/localg-host/watchghost.git')
+sha256sums=('SKIP')
+install=watchghost.install
pkgver(){
cd $srcdir/$name
@@ -22,7 +24,11 @@ package() {
cd "$srcdir/$name"
python3 setup.py build
python3 setup.py install --prefix=/usr --root="${pkgdir}"
-}
-sha256sums=('SKIP')
+ install -D $startdir/sysusers.conf $pkgdir/usr/lib/sysusers.d/watchghost.conf
+ install -D $startdir/watchghost.service $pkgdir/usr/lib/systemd/system/watchghost.service
+ for filename in groups loggers servers watchers ; do
+ install -D $srcdir/watchghost/watchghost/etc/$filename $pkgdir/etc/watchghost/$filename
+ done
+}