summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarl Smedstad2023-08-07 11:50:15 +0200
committerCarl Smedstad2023-08-07 12:05:43 +0200
commit64a78af9391110f76b8acb6cb03695aaa5a9ce44 (patch)
treeb5acfdcf495b587d7e939f5f49bf3f4ff1653ad5 /PKGBUILD
parent475c26ac2a3687f2ddadd71d81cbe228cb56d41e (diff)
downloadaur-64a78af9391110f76b8acb6cb03695aaa5a9ce44.tar.gz
Publish version 2023.08.07.00-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 897df0da1a0a..6bd8174a862c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Michael Louis Thaler <michael.louis.thaler@gmail.com>
pkgname=watchman
-pkgver=2023.07.24.00
+pkgver=2023.08.07.00
pkgrel=1
pkgdesc="Watches files and records, or triggers actions, when they change"
url="https://github.com/facebook/watchman"
@@ -24,6 +24,7 @@ depends=(
openssl
pcre2
python
+ xz
)
makedepends=(
boost
@@ -42,14 +43,16 @@ source=(
"watchman.json"
"watchman.service"
"watchman.socket"
+ "0001-Fix-build-with-fmt-10.patch"
)
sha256sums=(
- 'abef7859e6412a30f92941d811a0ef7e595a0ef8bfebb674f909743fdc3f5a46'
+ '8158efc9a6ecf56dbfd2c52cfd6689ca073655b909bf61100c0f88bf5c0b0720'
'd40feab6aa7dc6522c648660e88642fdf721ee1f9d80c23f6891a6381067a38b'
'3ebc93cb91ec9b9603969e222fd3ffd9baa4a1d07a7b3bd7aabf956ec2e177c8'
'ca3d163bab055381827226140568f3bef7eaac187cebd76878e0b63e9e442356'
'5b4b032b68d87d648e268c5c08b4d56993d5c1a661e3925b39f54bdef2dfbc42'
'853457ad70492fec9d7d020b9e067e2aec2ca419c0a5cddd5d93c5fab354c87a'
+ '90e5fd45b1e7380edddbcc9cdfc0eed2fae3696ac9da7c67fdc351b14a5d85f2'
)
_archive="$pkgname-$pkgver"
@@ -58,6 +61,7 @@ prepare() {
cd "$_archive"
patch --forward --strip=1 --ignore-whitespace --fuzz=3 --input="$srcdir/watchman-destdir.patch"
+ patch --forward --strip=1 --ignore-whitespace --input="$srcdir/0001-Fix-build-with-fmt-10.patch"
}
build() {