summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarl Smedstad2023-12-11 20:09:32 +0100
committerCarl Smedstad2023-12-11 20:09:32 +0100
commitc790a6e10b13b032037de9d0f39da1963c0c9718 (patch)
tree945f22d2779577717dd1c942fceff047c2e88007 /PKGBUILD
parentfd59109ec582a211d05caa6b567334c698d82bda (diff)
downloadaur-c790a6e10b13b032037de9d0f39da1963c0c9718.tar.gz
Publish version 2023.12.11.00-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 12 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2e62aeaedfd8..5969e6ec708c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Michael Louis Thaler <michael.louis.thaler@gmail.com>
pkgname=watchman
-pkgver=2023.12.04.00
+pkgver=2023.12.11.00
pkgrel=1
pkgdesc="Watches files and records, or triggers actions, when they change"
url="https://github.com/facebook/watchman"
@@ -26,7 +26,7 @@ depends=(
makedepends=(
boost
cmake
- gmock
+ gtest
rust
)
backup=(etc/watchman.json)
@@ -40,7 +40,7 @@ source=(
"watchman.socket"
)
sha256sums=(
- 'f7f664d74b00713a1aa93a5af7f849fb864d2e356d15213047a6c7bd89845533'
+ 'be28128a7affd26de921eaa1e74786d337530fe4a7fc42c70d8d376c9e45f6c9'
'd40feab6aa7dc6522c648660e88642fdf721ee1f9d80c23f6891a6381067a38b'
'3ebc93cb91ec9b9603969e222fd3ffd9baa4a1d07a7b3bd7aabf956ec2e177c8'
'ca3d163bab055381827226140568f3bef7eaac187cebd76878e0b63e9e442356'
@@ -76,8 +76,8 @@ build() {
check() {
cd "$_archive"
- # Skip failing tests - not sure why they fail.
_skipped_tests=(
+ # Skip failing tests - not sure why they fail.
'test_defer_state'
'test_even_more_moves'
'test_failingSpawner'
@@ -90,6 +90,13 @@ check() {
'test_local_saved_state'
'test_saved_state'
'test_scmHg'
+
+ # Skip long-running tests.
+ 'test_invalid_sock_access'
+ 'test_invalid_sock_group'
+ 'test_too_open_user_dir'
+ 'test_user_not_in_sock_group'
+ 'test_user_previously_in_sock_group'
)
_skipped_tests_pattern="${_skipped_tests[0]}"
for test in "${_skipped_tests[@]:1}"; do
@@ -108,5 +115,5 @@ package() {
install -Dm644 "$srcdir/watchman.service" "$pkgdir/usr/lib/systemd/user/watchman.service"
install -Dm644 "$srcdir/watchman.socket" "$pkgdir/usr/lib/systemd/user/watchman.socket"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
}