summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMiodrag Tokić2016-02-09 12:41:28 +0100
committerMiodrag Tokić2016-02-09 12:55:41 +0100
commit49032ebca7ec6214916befc05e9dbd9ad6ac7fc4 (patch)
tree8a13f9586f04e80abff8f39598275c219f74b83a /PKGBUILD
downloadaur-49032ebca7ec6214916befc05e9dbd9ad6ac7fc4.tar.gz
Initial import
Watson - A wonderful CLI to track your time! https://github.com/TailorDev/Watson
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37cf8f328be3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Miodrag Tokić
+
+pkgname=watson
+pkgver=1.2.0
+pkgrel=1
+pkgdesc='A wonderful CLI to track your time!'
+arch=('any')
+url="https://tailordev.github.io/Watson/"
+license=('MIT')
+groups=()
+depends=('python' 'python-arrow' 'python-click' 'python-requests')
+makedepends=('python-setuptools')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+
+source=("https://github.com/TailorDev/Watson/archive/${pkgver}.tar.gz")
+sha256sums=('3ef29a44c12e1b05f7af8569f90fa4cf110d2bc74b75ccadb74c45bb8efaad80')
+
+build() {
+ cd "$srcdir/Watson-${pkgver}"
+ sed -i '/pytest-runner/d' requirements.txt
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/Watson-${pkgver}"
+ install -D -m 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m 644 watson.completion "${pkgdir}/usr/share/bash-completion/completions/${pkgname}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}