summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlif Rachmawadi2017-04-11 08:25:39 +0700
committerAlif Rachmawadi2017-04-11 08:25:39 +0700
commit24d11c1da3c087feed337ae84500dcdb91800691 (patch)
treec53264be04bd93b8683853beaac3cccae257c1a8 /PKGBUILD
downloadaur-24d11c1da3c087feed337ae84500dcdb91800691.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d9fb9229910
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Alif Rachmawadi <code@subosito.com>
+
+pkgname=wavebox-bin
+pkgver=3.1.3
+pkgrel=1
+pkgdesc="The next generation of web-desktop communication"
+arch=('x86_64' 'i686')
+url="https://wavebox.io/"
+_repourl="https://github.com/wavebox/waveboxapp"
+license=('Mozilla Public License version 2.0')
+options=(!strip)
+provides=('wavebox')
+depends=('gconf' 'gtk2' 'libxtst' 'nss' 'alsa-lib' 'libxss')
+optdepends=('gvfs' 'libnotify')
+
+source=('wavebox.desktop')
+source_x86_64=("${_repourl}/releases/download/v${pkgver}/Wavebox_${pkgver//./_}_linux_${CARCH}.tar.gz")
+source_i686=("${_repourl}/releases/download/v${pkgver}/Wavebox_${pkgver//./_}_linux_ia32.tar.gz")
+
+sha512sums=('a6a55a0b0597eea63e2869ab27e3ddab802b020c89059b0b32399b63e64f0271e4685e363448da71c6ba90c810b83542cd0c9f40e2ce49057a8e33c54b82663b')
+sha512sums_x86_64=('e115bfeebc0e10422c57194450e6ebfea6525a6818bef011647076453f422b9fa8d43920cef95dd11b04008c00bab6403e1bbe7338606b73277abce4fd6d0dc5')
+sha512sums_i686=('1a68c83b70b9db2b3cca4e41be22fd1eff216ee58df5b5493fc2017d7323d02a59c3cdb6379c95c93be80b3a0ad864d66af18cbb6e70846c416d25fb45fdbb32')
+
+package() {
+ if [ ${CARCH} == "x86_64" ]; then
+ cd ${srcdir}/Wavebox-linux-x64
+ else
+ cd ${srcdir}/Wavebox-linux-ia32
+ fi
+
+ mkdir -p "${pkgdir}/usr/bin"
+ mkdir -p "${pkgdir}/usr/share/wavebox"
+ mkdir -p "${pkgdir}/usr/share/applications"
+
+ cp -R ./* "${pkgdir}/usr/share/wavebox"
+ cp "${srcdir}/wavebox.desktop" "${pkgdir}/usr/share/applications/wavebox.desktop"
+ ln -s "/usr/share/wavebox/Wavebox" "${pkgdir}/usr/bin/wavebox"
+}