summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander Courtis2021-10-13 14:46:35 +1100
committerAlexander Courtis2021-10-13 14:46:35 +1100
commit6949e3743a6398524a3ec1a00b01ac5d5d810b9b (patch)
tree83d47256cb6fcd0a4681f1ea6cd1b4c1791201b6 /PKGBUILD
downloadaur-6949e3743a6398524a3ec1a00b01ac5d5d810b9b.tar.gz
1.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3482c6c27f80
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Alexander Courtis <alex@courtis.org>
+pkgname=way-displays
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="way-displays: Manage Your Wayland Displays"
+arch=('x86_64')
+url="https://github.com/alex-courtis/way-displays"
+license=('MIT')
+depends=('wayland' 'wlroots' 'libinput' 'yaml-cpp')
+makedepends=('git' 'make' 'gcc')
+source=("https://github.com/alex-courtis/way-displays/archive/refs/tags/1.0.0.tar.gz")
+sha256sums=('5d51b74f7c9ea21c7503222d84a9f74f3832890bc7d0b86201033f56395e7a42')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make way-displays
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make PREFIX="/usr" PREFIX_ETC="" DESTDIR="$pkgdir/" install
+}
+