summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDanct122022-02-14 11:47:09 +0700
committerDanct122022-02-14 11:47:09 +0700
commitaad9dcb307cc0ee98f36d7acba4f0034ca49c1f8 (patch)
tree693156855fc9b7afe21e50fb13cdef708ed0dbb3 /PKGBUILD
parent8a4b43c41d5a5829210edf6f4c858151ec3d234b (diff)
downloadaur-aad9dcb307cc0ee98f36d7acba4f0034ca49c1f8.tar.gz
fix bad eol on proc dt values
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d61801b373b1..eabbf6e6a865 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=waydroid
pkgver=1.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="A container-based approach to boot a full Android system on a regular Linux system"
arch=('any')
url='https://github.com/waydroid'
@@ -14,13 +14,19 @@ optdepends=('waydroid-image: Android image for use with waydroid'
'python-pyclip: share clipboard with container')
_commit="9a87b10bbfd9cc04c8259207233fadad9acbf5d3" # tags/1.2.0
source=("waydroid::git+https://github.com/waydroid/waydroid.git#commit=$_commit"
- gbinder.conf)
+ gbinder.conf
+ 0001-fix-bad-eol-of-proc-dt-values.patch)
pkgver() {
cd "$pkgname"
git describe --tags | sed 's/^v//;s/-/+/g'
}
+prepare() {
+ cd waydroid
+ patch -p1 < ../0001-fix-bad-eol-of-proc-dt-values.patch
+}
+
package() {
cd waydroid
install -dm755 "$pkgdir/usr/lib/waydroid"
@@ -37,4 +43,5 @@ package() {
}
sha256sums=('SKIP'
- '87a21d401281735ea026d715ea79b36e01f9af084198de2761b32d5b58a343dd')
+ '87a21d401281735ea026d715ea79b36e01f9af084198de2761b32d5b58a343dd'
+ 'a0f2f5fe6c3e5af6afee144ad6deec067679d39a9544dfaa2d10e8dac7013bf8')