summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeorge Rawlinson2021-06-22 01:27:07 +0000
committerGeorge Rawlinson2021-06-22 01:27:07 +0000
commit33831d1361ed0f2c928e8092ed569d207f12a51e (patch)
treeb67261e8898bb0728a3ddbfd1a017f525a18b9dc /PKGBUILD
parentaaec45e5cea78ca4e3ad1761fa40059456abe25c (diff)
downloadaur-33831d1361ed0f2c928e8092ed569d207f12a51e.tar.gz
addpkg: waypoint 0.4.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 12 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c1d396de74ed..091daddcd064 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,22 @@ pkgdesc="A tool to build, deploy, and release any application on any platform"
arch=('x86_64')
url="https://www.waypointproject.io/"
license=('MPL2')
-depends=('glibc')
makedepends=('go' 'go-bindata')
source=("$pkgname-$pkgver.tar.gz::https://github.com/hashicorp/waypoint/archive/v$pkgver.tar.gz")
b2sums=('c17499223e5f8ed4bb7407d33ff8c798cb50a8a5db00730faa3cb4256953b2e6f128c69f5aae005dc49ec33e8d52895b3b9941c41ca26721a5745bb1f1e451a5')
+prepare() {
+ cd "$pkgname-$pkgver"
+ sed -e "s/^GIT_COMMIT.*/GIT_COMMIT = ${pkgver}/" \
+ -e "s/^GIT_DESCRIBE.*/GIT_DESCRIBE = tarball/" \
+ -e "s/\$\(GIT_IMPORT\)//" \
+ -e "/^GIT_DIRTY.*/d" \
+ -e "s/\$(GIT_DIRTY)//" \
+ -e "/^LAST_RELEASE.*/d" \
+ -e "/^THIS_RELEASE.*/d" \
+ -i Makefile
+}
+
build() {
cd "$pkgname-$pkgver"
make bin