summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeorge Rawlinson2021-06-24 01:50:56 +0000
committerGeorge Rawlinson2021-06-24 01:50:56 +0000
commitf7f137d60917e8418fd8fefe28b93e9768cf45db (patch)
treec61622471906eec30007693184a85a6eb500eae3 /PKGBUILD
parent33831d1361ed0f2c928e8092ed569d207f12a51e (diff)
downloadaur-f7f137d60917e8418fd8fefe28b93e9768cf45db.tar.gz
upgpkg: waypoint 0.4.0-2
Changed build process.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 24 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 091daddcd064..98e8e2f3111c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=waypoint
pkgver=0.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="A tool to build, deploy, and release any application on any platform"
arch=('x86_64')
url="https://www.waypointproject.io/"
@@ -11,21 +11,31 @@ makedepends=('go' 'go-bindata')
source=("$pkgname-$pkgver.tar.gz::https://github.com/hashicorp/waypoint/archive/v$pkgver.tar.gz")
b2sums=('c17499223e5f8ed4bb7407d33ff8c798cb50a8a5db00730faa3cb4256953b2e6f128c69f5aae005dc49ec33e8d52895b3b9941c41ca26721a5745bb1f1e451a5')
-prepare() {
- cd "$pkgname-$pkgver"
- sed -e "s/^GIT_COMMIT.*/GIT_COMMIT = ${pkgver}/" \
- -e "s/^GIT_DESCRIBE.*/GIT_DESCRIBE = tarball/" \
- -e "s/\$\(GIT_IMPORT\)//" \
- -e "/^GIT_DIRTY.*/d" \
- -e "s/\$(GIT_DIRTY)//" \
- -e "/^LAST_RELEASE.*/d" \
- -e "/^THIS_RELEASE.*/d" \
- -i Makefile
-}
-
build() {
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+
+ # build process extracted from Makefile
cd "$pkgname-$pkgver"
- make bin
+ go build \
+ -o ./internal/assets/ceb/ceb \
+ ./cmd/waypoint-entrypoint
+
+ cd internal/assets
+ go-bindata \
+ -pkg assets \
+ -o prod.go \
+ -tags assetsembedded \
+ ./ceb
+
+ cd "$srcdir/$pkgname-$pkgver"
+ go build \
+ -tags assetsembedded \
+ -o ./waypoint \
+ ./cmd/waypoint
}
package() {