summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVincent Grande2021-03-16 22:17:04 -0400
committerVincent Grande2021-03-16 22:17:04 -0400
commit937a09e4f5834b0fe43aab656158a616d6516c81 (patch)
treeff55748821cf56de1b5a2083e936ca1ca9698511 /PKGBUILD
downloadaur-937a09e4f5834b0fe43aab656158a616d6516c81.tar.gz
initial upload
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..086bcda86297
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: AntonĂ­n Dach <dach@protonmail.com>
+
+pkgname=wayst-wayland-git
+pkgver=r146.18a038b
+pkgrel=1
+pkgdesc='Simple terminal emulator for Wayland and X11 with OpenGL rendering and minimal dependencies.'
+arch=('x86_64')
+url='https://github.com/91861/wayst'
+license=('MIT')
+depends=('mesa' 'freetype2' 'fontconfig' 'libxkbcommon' 'libxrandr')
+optdepends=('libutf8proc: unicode normalization')
+makedepends=('git')
+provides=('wayst')
+conflicts=('wayst')
+source=('git+https://github.com/91861/wayst.git#branch=master')
+md5sums=('SKIP')
+
+pkgver() {
+ cd wayst
+
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+
+}
+
+build() {
+ cd wayst
+
+ make window_protocol=wayland
+}
+
+package() {
+ cd wayst
+
+ mkdir -p "$pkgdir/usr/bin"
+ make INSTALL_DIR="$pkgdir/usr/bin" install
+}