summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorepitron2017-05-24 22:44:11 -0400
committerepitron2017-05-24 22:44:11 -0400
commit601814887947da1b94f72a2b3da912ce79b5a129 (patch)
tree1172a30b0539687776dbe839bcdc1e547b5d197f /PKGBUILD
downloadaur-601814887947da1b94f72a2b3da912ce79b5a129.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..beac85472e4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Mantainer: epitron <chris@ill-logic.com>
+
+pkgname=wcc-git
+_pkgname=wcc
+pkgver=0.0.1.r1.g391ae30
+pkgrel=1
+pkgdesc="The Witchcraft Compiler Collection"
+arch=('i686' 'x86_64')
+license=('MIT')
+depends=(capstone glibc binutils zlib libelf readline gsl)
+makedepends=(git make)
+provides=(wcc)
+conflicts=(wcc)
+source=("git+https://github.com/endrazine/wcc.git")
+sha256sums=(SKIP)
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+}
+
+prepare() {
+ cd "$_pkgname"
+ git submodule init
+ git submodule update
+}
+
+build() {
+ cd "$_pkgname"
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ mkdir -p "${pkgdir}/usr/bin"
+ make DESTDIR="${pkgdir}/" install
+}