summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormatheusfillipe2022-03-01 21:54:33 -0300
committermatheusfillipe2022-03-01 21:54:33 -0300
commit5a35a0f09f3cdb7105e2c2d84840e615eaee0201 (patch)
tree03f58bf9788dfc02a578714b67c21c88b5d78fce /PKGBUILD
downloadaur-5a35a0f09f3cdb7105e2c2d84840e615eaee0201.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb478555a368
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer mattf <matheusfillipeag@gmail.com>
+
+pkgname=wcofun
+pkgver=r34.0118b37
+pkgrel=1
+pkgdesc="Stream and download animes directly from your terminal."
+url="https://github.com/matheusfillipe/wcofun.cli"
+license=('MIT')
+arch=('any')
+md5sums=('SKIP')
+makedepends=(git)
+depends=(curl coreutils htmlq jq fzf rofi mpv bash)
+optdepends=('curl-impersonate-chrome: Bypass cloudflare blocks solving not found errors'
+ 'rofi: GUI menu'
+ 'dmenu: GUI menu')
+provides=(wcofun)
+source=("git+$url")
+
+pkgver() {
+ cd ${pkgname}.cli
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package () {
+ cd ${pkgname}.cli
+ install -Dm755 wcofun "${pkgdir}/usr/bin/${pkgname}"
+}