summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Peukert2024-01-28 00:30:59 +0100
committerDaniel Peukert2024-01-28 00:30:59 +0100
commit8b30a49c42f50a34146081ab300d50eeea252c82 (patch)
treedf8383a7264359399e7bd15aed12d4734f401a25 /PKGBUILD
parent902000dc4e9aa3330b1d99bbb385fecad47c0641 (diff)
downloadaur-8b30a49c42f50a34146081ab300d50eeea252c82.tar.gz
Build weatherspect from source archive
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ae9efa50ee0a..bf69d9039509 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,35 +4,37 @@
# Contributor: archlinux.info:tdy
pkgname='weatherspect'
pkgver='2.0'
-pkgrel='2'
+pkgrel='3'
pkgdesc='A virtual weather environment in ASCII'
arch=('any')
url="https://github.com/AnotherFoxGuy/$pkgname"
license=('GPL-2.0-only')
depends=('perl' 'perl-compass-points' 'perl-json' 'perl-term-animation')
source=(
- "$pkgname-$pkgver::$url/raw/$pkgver/$pkgname"
+ "$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
"$pkgname-$pkgver-fix-w-bug.diff::$url/commit/b7ac28234c1e93e537787d163ac80361296aaf58.diff"
'devendor.diff'
"$pkgname.1"
)
-sha512sums=('39c277f933f9764df11ff6267bbf3dbd322a1fa83404190417c5e022dae0bf1b8f5d35b363759da5a2aaa1959c61f3f50315c8cf72abe7965aafb7190b5e7c60'
+sha512sums=('b459eeb93a2790ae9ed72f9fbd8a066de3adfb529c42739e8d4350809ee611d3f15c49b4930ba4e9b50d683030fd6c979fddf83074446007e80d5bbe85e2c2e2'
'8102f7f325d5979ff78f721507aa0e7623a990fa73d311eebb3ba394945d42819ae91e7af5952fbf34373bff49da4e97afbe84a17b5e3e0f0159f9ea825cb686'
'10e416693897551d3ab11b81f0a4d2d9df71957dd4b8abd780d9a09473d7fa7846867178760f95c5502c5fac3ee4089185ccf0edf8b1c937f17ffec32b530ca3'
'494dcc31151912ae6965a6c7f6323f1c3fbfa01f1eadc72838e605917ab6a4df4aba95aab2a891070eb928817b35240eecfa3d6a4fc285ff8a4e729044968caa')
+_sourcedirectory="$pkgname-$pkgver"
+
prepare() {
- cd "$srcdir/"
+ cd "$srcdir/$_sourcedirectory/"
# Devendor perl-compass-points
- patch --follow-symlinks --forward -p1 "$pkgname-$pkgver" < 'devendor.diff'
+ patch --forward -p1 < '../devendor.diff'
# https://github.com/AnotherFoxGuy/weatherspect/commit/b7ac28234c1e93e537787d163ac80361296aaf58
- patch --follow-symlinks --forward -p1 "$pkgname-$pkgver" < "$pkgname-$pkgver-fix-w-bug.diff"
+ patch --forward -p1 < "../$pkgname-$pkgver-fix-w-bug.diff"
}
package() {
- cd "$srcdir/"
- install -Dm755 "$pkgname-$pkgver" "$pkgdir/usr/bin/$pkgname"
- install -Dm644 "$pkgname.1" "$pkgdir/usr/share/man/man1/$pkgname.1"
+ cd "$srcdir/$_sourcedirectory/"
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "../$pkgname.1" "$pkgdir/usr/share/man/man1/$pkgname.1"
}