summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Peukert2020-04-23 21:27:58 +0200
committerDaniel Peukert2020-04-23 21:27:58 +0200
commit35ae656b9cb657de904ba8b9bdc3560b0111bb7a (patch)
tree3741f11ea9ce4d46c1d1c3665ca5d8ed4daf3c57 /PKGBUILD
parent03dd68162c0313342a841617a36c2e0240704045 (diff)
downloadaur-35ae656b9cb657de904ba8b9bdc3560b0111bb7a.tar.gz
Unify git pkgver functions
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 607006608976..c60c686ba32a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: archlinux.info:tdy
_pkgname='weatherspect'
pkgname="$_pkgname-git"
-pkgver='2.0.r2.gb7ac282'
+pkgver='2.0.r3.g0f85875'
pkgrel='1'
pkgdesc='A virtual weather environment in ASCII - git version'
arch=('any')
@@ -25,7 +25,7 @@ _sourcedirectory="$pkgname"
pkgver() {
cd "$srcdir/$_sourcedirectory/"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed -e 's/-\([^-]*-g[^-]*\)$/-r\1/' -e 's/-/./g'
}
package() {